My SBM Plugins on WordPress 2.5, another patch

Thanks to Xred, who found this problem :)

When users tried to enable the patched version of SBM, they might be encounter a fatal error which says something like Cannot redeclare register_sidebar(), thus here’s another dirty but effective patch:

In the patched version of sbm.php, after:
global $pagenow;
add:
if( $pagenow == 'plugins.php' ) return; // to make it possible to be enabled

And now we should be able to enable SBM :p

I’ve also updated the patched file, you can download it here.